Certificate Based Authentication 2.0

In this lab you will be deploying a certificate to an enrolled Windows 10 virtual machine.
This certificate will be generated by the built-in CA in Workspace ONE UEM.

We will later configure Workspace ONE Access to trust certificates issued by UEM and
configure the Certificate (Cloud Deployment) authentication adapter.

Finally we will test everything on a Windows 10 vm to ensure we are able to have a
seamless authentication experience.

Extra Material is optional and will show you how to suppress the pop-up users see in
Chrome and to automate this using UEM.

Part 1: WorkspaceOne UEM - Certificate Profile

= C (0 & dwlivefire.awmdm.com/AirWatch/Login?ReturnUrl=%2FAirWatch%2F

Y

<

Workspace ONE" UEM

Username

’ sfrank@vmware.com

(I Remember

Trouble logging in

1. Onyour ControlCenter jumpbox
1. Open Google Chrome
2. Navigate to https://cn-livefire.awmdm.com
3. Authenticate using :
+ Username your e-mail address
+ Password VMware1! (if you didn't change it from the default)
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Settings

~ System
Gettng Started
Branding

~ Enterprise Intagration

Livefire

System » Enterprise Integration

Workspace ONE Access

Enterprise Integration Services

Certificate Autharities
Content Gateway
Cloud Connector

Directory Services

Emall (5h

Vi el

Wi el Prowy
* Peer Distribu

Third-Par

SMS
Pull Service Installers
Syslog
* Workspace ONE Access
Configuration
Acress Management
+ Security
Help
* Locakzation
Termas of Use
SIMIME
+ Advanced
* Devices & Users

* Cantent

* Apps

3 Ernall

Server

Establi

apps

USE AUTOG ENERATED API KEY

rust between users, devices and the hybrid cloud for 2 seamless user experience and powerful condrional access to a unffied app ¢t

ENABLED
ENABLE

ce ONE Access-UEM configuration to use Auto-Genes

Certificate

Enabie Workspace ONE UEM cermificare p
trust with Warkspace ONE Access 3

Cartificare Frovisioning

E for upe with Warkspace OME Access and Mabile 5501 Expart the issuer certficare on tis p

apters
ENABLE

2. Inthe Workspace ONE UEM Console

* Navigate to Groups & Settings > All Settings > System > Enterprise Integration >

Workspace ONE Access > Configuration

Settings
SIS
Pull Service Installers
Syslog
Remote Management
v Workspace ONE Access
Configuration

Access Management

v

Security

Help

w

Localization
Terms of Use
S/IMIME

» Advanced

> Devices & Users

> Content

Global / Livefire v

B L

ENADGLE

Use this Action Button to update Workspace ONE Access-UEM configuration to use Auto-
Generated UEM AP| Key

USE AUTOGENERATED APl KEY

* Certificate

Enable Workspace OME UEM certificate provisioning for use with Workspace ONE Access and
Mobile S50. Export the issuer certificate on this page so that you can establish trust with

Workspace ONE Access authentication adapters.

Certificate

Provisioning

DELETE

3. Inthe Enterprise Integration > Workspace ONE Acces page

+ Scroll down to find the Certificate section

Certificate Based Authentication 2.0
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« Under Certificate select ENABLE (if not already enabled)

Certificate

Enable Workspace ONE UEM certificate provisioning for use with Workspace ONE Acc
Mobile SSO. Export the issuer certificate on this page so that you can establish trustv
Workspace ONE Access authentication adapters.

Certificate Type Pfx
Valid Fro... 5/16/2020
ValidTo  5/18/2040
Thumbp... 86C33DC6D225BD01B536AD684BA191AD234E

Issuer Certificate EXPORT

S/MIME

o This type of file can harm your com)
want to keep VidmaAirw:

E vidmAirWatchRoot...cer

©,

4. Inthe Enterprise Integration > Workspace ONE Acces page
* In the Certificates section
+ Select EXPORT
« When prompted, select Keep
« Note this will download a .cer file (VidmAirWatchRootCertificate.cer)
+ Close the Settings window in the top right-corner, by selecting x
« NOTE: You may have downloaded this certificate in a prior lab you can leverage this
certificate.
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q:j:l Workspace ONE UEM Global / Livefire ~ Q Q < @ Administrator

GETTING Dashboard Devices » Profiles & Resources
STARTED
List View f
Profiles A
MONITOR Device Updates
Lifecycle > Filters » [ ADD W l [ LAYOUT ¥ l [ EXPORT l Search List
Profiles & Resources A Profile Details AddRrofile 3y Assignment Type Assigned Groups  Inst
[=er]
=} Profiles CIpload Profie
ACCOUNTS
Baselines Batch Import
e Resources No Records Found
BOOKS
Batch Status
0O
CONTENT Profiles Settings >
- Compliance Policies >

5.

6.

In the Workspace ONE UEM admin console
+ Navigate to Devices > Profiles & Resources > Profiles > ADD > Add Profile

Add Profile

Select a platform to start:

Select Device TM

Select Context

- L
P 0

22 Add a New Windows Desktop Profile

In the Add Profile window
 Select Windows > Windows Desktop > User Profile
+ Under General
* Next to Name: type W10 - SCEP - S50 .
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Deployment Managed ¥
Assignment Type Auto v
Allow Remaval Always v
Managed By ManfredVogal@gmail.com

Smart Groups @ ManfredVogal@gmail.com (ManfredVo

gal@gmail.com)

fStart typing to add a group

YES

7. Inthe Add a New Windows Desktop Profile
* In the General tab,
+ Scroll down to Smart Groups

+ Select you Organization Group (This should be your e-mail address) with the

world icon next to it.

General

VPN

Credentials
Windows Hello
Single App Mode
Web Clips

Exchange ActiveSync

Exchange Web
Services

SCEP

| CONFIGURE I

8. Inthe Add a New Windows Desktop Profile
* In the LEFT MENU, navigate to the SCEP
+ Select CONFIGURE
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SCEP

AirWatch Certificate Authority
Certificate Authority * AirWatch Certificate Authority
ficate Template * Certificate (Cloud Deployment)

Software

SAVE AND PUBLISH C

9. Inthe Add a New Windows Desktop Profile
+ Under SCEP, Set the following, next to:
+ Credential Source: AirWatch Certificate Authority
+ Certificate Template: Certificate (Cloud Deployment)
+ Key Location: Software
+ Select SAVE AND PUBLISH at the bottom right of the window

View Device Assignment b
Assigniment Status | Al w B i ]

[P nid o &0

@ sdded B i o ajonnetuE
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10. On the View Device Assignment page
+ Confirm your device is showing
* Select PUBLISH

Troubleshooting Tips

Should the certificate not get deployed please follow the steps below to force the certificate
to be pushed.

—
exmm

Management Clients

OMA-DM VMware Workspace ONE Intelligent
Hub

Description Native MDM client built into the device  Workspace ONE Intelligent Hub.
installed on the device

Communication  WNS. AWCM

1. We have observed in certain scenarios the device is reporting WNS STATUS:
DISCONNECTED when it should be WNS STATUS: CONNECTED. This can lead to a delay in
the client certificate being deployed to the device. In the communication flow WNS (Windows
Notification Services) are responsible for triggering a check in between the OMA-DM client
and the Workspace ONE UEM Server. Network constraints can sometimes play a role and we
recommend seeing Microsoft's guidelines: https://via.vmw.com/w10WNS
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https://via.vmw.com/w10WNS

Devices  »  List View < 2/4 >

Recent List
ManfredVogal@gmail.com V... [Tquenv | seno | tock | womeactions v
VWhware Virtual Platform 10.0.18363 | ©Ownership: Co...
Summary Compliance Profiles Baselines Apps Updates Content More w
(@ Last Scan: ‘
| export v | [search List |
Status Profile Details Organization Group Configuration Type Assignment Type
o @ W10 - Chrome - ADMX ManfredVogal@gmail.com Device Automatic
O @ W10 - Chrome - AutoSelect ManfredVogal@gmail.com User Automatic

C‘_ W10 - SCEP- 550 ManfredVogal@gmail.com User Automatic

Pending Install

2. In the WorkspaceONE UEM Console navigate to Device > List View > Select the unique VM
you are working on (Previously W10Client01).
+ Select the Profiles tab.
+ If you are getting a green tick the certificate ha been deployed and you can move to part

2 of the lab.
+ However if you are getting a grey tick it means the profile is pending install.
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Best match

Access work or school
System settings

Search the web

,O access work - See web results

p access work outlook from home
£ access wark or school settings
£ access worked

£ access work outlook

/O access work or school

P access work or school page

O access work or school systems

IO ACCESS WUFH

3. Navigate to the Windows 10 VM and type access work into the search and click the Access

work or School System settings

Settings

far Home

Access work or school

Find a setting

Accounts

A= Your info

E Email & accounts
@b Sign-in options
| B9 Access work ar school
A, Other users

55 Sync your settings

ask them,

Connect
+

E Connected to Workspace ONE MDM
Connected by mark@euc-livefire.com

E Connected to EUC-LIVEFIRE AD domain

euc-livefire.com

Get access to resources like email, apps. and the network. Connecting
means your work or school might control some things on this device,
such as which settings you can change. For specific info about this,

4. Click on Connected to Workspace ONE MDM

* Click on Info
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€ Settigs

@ Managed by Workspace ONE

Management Server Address:
[ wmdm Dm.sve/token/
lw8dE/2FCICIASD21ABEAFEBTISIZABC 315624

Exchange ID:

DE012F6CDEBBBD0543DATESDE0663610

Device sync status

Syncing keeps security policies, network profiles, and managed
applications up to date.

Last Attempted Sync:

The sync was successful

5/13/2021 5:31:00 AM

Advanced Diagnostic Report

Your IT or support person may want additional information to help with
troubleshosting.

Create report

@ Get help

Manfredvogal@gmail.com D... [ T v -

Summary compliance Profiles Baselines Apps. Updates Content More v

© Last scan
Stotus  Prafe Detals
© W10 - Chrome - ADMX Manfregvogal@gmallcom  Device Automatic
L] W10 - Chrome - AutoSelect Manfredvogal@gmallcom  User Automatic

W10 - SCEP- S50 Manfregvogalmgmallcom  User Automatic

5. Scroll to the bottom of the page and click Sync
* This should trigger a manual check in with WorkspaceONE UEM and trigger the
deployment of the certificate. Allow for a few minutes while this process takes place.
+ Double check in the WorkspaceONE UEM console to make sure that there is now a Green
tick next to the W10 - SCEP - SSO profile.

[ Registry Editor - ]
File Edit View Favontes Help
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EnterpriseResourceManager Tracked CEET96ET-9984-40BC- BEOF-8AS5DBF1DDC T S-1-5-21-2061497567-236163"

Enrollments A || Name Type Data
b (Default) REG_SZ (value not zet)

w Enterprised ppMar
w | Database
i L] TelEnrolim
Tol_XAPReq
EmterpriseCertifics
EnterpriseDataPro
v | EnterpriseResourc
DoMotTrack
i ow | Tracked
i~ | CEET96B7-9
) device
v 51521
| defau
P EventSounds
'i Consclel - [Console Root\Certificates - Current User\Personal Certificates]

i File Action View Favorites Window Help

e« alF {2/ XE= EE

_ Console Root A ) lssued To . lssued By Expiration Diat|
v cf“:"“ﬁ . Coment i T2FC1CIAID21ABGAFER1151288.., AirWatchCa 511172031
M frsena. i ManfredVogalgmailcom i
— Certificates 5

© Trusted Root Centification Authorit
» [ Enterprise Trust
» = Intermediate Certification Authoril
=~ Active Directory User Object
. Trusted Publishers
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6. Should you require further troubleshooting check this registry key for installed profiles -

Computer\HKEY LOCAL MACHINE\SOFTWARE\Microsoft\EnterpriseResourceManager\
Tracked

You can also check the Certificate store in MMC under Personal > Certificates to ensure you
have the client certificate installed.

Part 2 : Configure Workspace ONE Access

O 3 H l -

1. Onyour ControlCenter server
* In the Chrome browser
+ Navigate to your unique Workspace ONE Access tenant.
+ Authenticate using
+ username: Administrator
+ password: VMware1!

* In the Web Intelligent Hub
* In the top right corner, select the TA Icon
* In the Tenant Admin interface
+ Select
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Show apps
Workspace ONE™ Access Local Admin ~ F_ﬁ ACCE

Dashboard ~ Users & Groups Catalog ~ Identity & Access Management Appliance Settings Roles O\

Directories Identity Providers Password Recovery Assistan Authentication Methods Policies

Authentication Methods for Built-in Identity Providers

Important: When you disable an authentication method, the authentication method is removed as a choice in the access policy rules page. Make
sure you update the access policy rules to select another authentication method.

Authentication Methods Configure Status

Device Compliance (with Workspace
ONE UEM)

Disabled

Password (with Workspace ONE UEM) Disabled

Viware Verify Enabled
Mobile SSO (for i0S) Disabled
Password (Local Directory) Enabled
Mabile SSO (for Android) Disabled

Certificate (Cloud Deployment) Disabled

l NN N ~
A

2. Inthe Workspace ONE Access admin console
+ Navigate to ldentity & Access Management > Authentication Methods.
+ Select the pencil icon next to Certificate (Cloud Deployment)

Certificate (Cloud Deployment)
Enable Certificate
Adapter
When enabled, S5L termination cannot be done on the Load Balancer (Load Balancer needs to be configured as

Root and intermediate CA Select File
certificates*

You can upload multiple DER and PEM root and intermediate CA ceriificates including concatenated PEM files
Uploaded CA Certificates  CN=Livefire (JC3F7E62F73568A9A73649A0EEBF63394B86T05B2ET23AE2751T0FSE939386EF) &

User Identifier Search

upn | subject v
Order
Select the search order for locating the user identifier within the certificate. upn: UserPrincipalName value from
the Subject Alternative Name; email: Email address from the Subject Alternative Name; subject: UID value from
the Subject
Validata 1IDM Foanmat .’
L MName D: ™
# Quick access
VidmAirWatchRootCertificate.cer 5/
I Desktop * W
hware Workspace htm 5/
* Downloads  # Whware Workspace OME_files 5/
Documents  # uandenlov ETAd
=1 Dirtirrar = R4 RO v

File name: | VidmAirWatchRootCertificate.cer

3. Inthe Certificate (Cloud Deployment) page
+ Select the tickbox to Enable Certificate Adapter
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+ Select Select File for the Root and Intermediate CA Certificates
+ Select the certificate we have downloaded from the UEM console earlier
+ Select Open

Update Auth Adapter
Please click OK to confirm and upload file.

Certificate (Cloud Deployment)

certificates™

You can upload muliple DER and PEM root and intermediate CA certificates including concatenated PEM files
Uploaded CA Certificates  CN=Livefire (9C3FT7EG2F73568A9A73649A0EEBF63394B26705B2E723AE275170FSE939386EF) 2

User Identifier Search

upn | subject v
Order
Select the search order for locating the user identifier within the certificate. upn: UserPrincipalName value from
the Subject Alternative Name; email: Email address from the Subject Alternative Name; subject: UID value from
the Subject
Validate UPN Format b
Validate the format of the UserPrincipalName field
Request Timeout 0

Timeout in seconds to wait for a response. A value of zero will wait indefinitely.

Cancel

4. Inthe Update Auth Adapter window
+ Select OK.

* In the Certificate (Cloud Deployment) window
+ At the bottom of the page, select Save
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By VVOIESPACE WING MUD JETVICE A | T Favories | viviware intemge: A G VIVIWware workspace wiNe . B

< C {} @& aw-grantztrnelnovtestvidmpreview.com/SAAS/admin/identity

3 Apps @ my-iplivefirelab/ip [ VMware Horizon® @ UAG-HZN @ UAG-UEM | NSX manager ofs 4;

® Workspace ONE™ Access

Identity & Access Management

Password Recovery Assistant Auwenucavon Methods Policie}

Dashboard =+~ Users & Groups Catalog ~

Directories Identity Providers

Identity Providers (3)

Identity Provider Name Auth Methods Directory

, o
Sl By SN Password (Local Directory) System Directory

Password (cloud deployment) LivefireSync

ST LivesraSnc Password (cloud deployment)  LivefireSync

5. In the Workspace ONE Access Console
+ Navigate Identity Providers
+ Under Identity & Access Management, select on Built-in

Directories Identity Providers Password Recovery Assistant Authentication Methods Policies

Authentication Methods Select which authentication methods the IdP will use to authenticate users
Authentication Methods Associate Authentication Method
Password (Local Directory) "
—_—
Certificate (cloud deployment) "
b
Connector(s) | WS_1Connector (ws1-connector.euc-livefire.com) 3
Add a Connector *ou can select additional connectors for high availability {HA). Create the

connector activation code from the Add a Connector page and set up the
connector, and then select the connector for this IdP.

Important: For high availability, each connector must have the same
authentication method configuration.

Connector Authentication

Authentication Methods Associate Authentication Method
Methods.

Password (cloud 4

deployment)
KDC Certificate Export Download Certificate

Export the KDC server root certificate for use in a Mobile Device Management profile

Cancel

6. In the Built-In page
+ Navigate to the Authentication Methods area
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+ Select the check box next to Certificate (Cloud Deployment)
+ Select Save at the bottom of the page.

@ Workspace ONE™ Access

Dashboard ~ Users & Groups Catalog - Identity & Access Management Roles

Directories Identity Providers Password Recovery Assistant Authentication Methods Policies

ADD POLICY EDIT DEFAULT POLICY I l NETWORK RANGES

Policy Name Applies to Rule

1 Application(s) 2R

7. Inthe Workspace ONE Access console
+ Navigate to Identity & Access Management > Policies
 Select default_access_policy_set

< BACK

default_access_policy_set

I EDIT I

Definition

8. Under Policies \ default_access_policy_set
« Select EDIT
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Edit Policy

1 Definition

2 Configuration

3 Summary

You can create a list of rules to access the applications selec
of devices that can access the applications, the auth method
application before reauthenticating.

MNetwork Range Device Type

ALL RANGES Web Browser

ALL RANGES Workspace ONE App ..
DY AR/ Al e Rl e

10.

In the Edit Policy page

+ Select the second tab from the left column Configuration
+ Select All Ranges next to Web Browser in the Device Type Category

Then perform this action
then the user may authenticate using *

If the preceding method fails or is not
applicable, then

If the preceding method fails or is not
applicable, then

Re-authenticate after

-

CAMNCEL SAVE

Authenticate using... L @

Certificate (Cloud Deployment) . ©@®
Password (cloud deployment) y @ ®
Password (Local Directory) . @ @®

(¥ ADD FALLBACK METHOD

a8 Hour.. - @

In the Edit Policy Rule page, edit the following next to:
+ then the user may authenticate using * change to : Certificate (Cloud Deployment)

Certificate Based Authentication 2.0
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+ if preceding method fails or is not applicable then change to Password (Cloud

Deployment),
 then Select ADD FALLBACK METHOD
+ Select Password (Local Directory) as the third authentication option.
+ Select SAVE at the bottom of the window

You can create a list of rules to access the applications selt
of devices that can access the applications, the auth meth

application before reauthenticating.

Device Type

Web Browser

Workspace ONE App .

® ADD POLICY RULE

11. In the Edit Policy \ Configuration page
+ Select ADD POLICY RULE

Certificate Based Authentication 2.0 Export Date: 2024-01-09 04:26:44 -0500
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If & user's network range is *

and the user accessing content from *

and user belongs to group(s)

and user is registering FIDO2 authenticator *

Then perform this action

then the user may authenticate using *

If the preceding method fails or is not applicable, then

If the preceding method fails or is not applicable, then

ALL RANGES

Windows 10

T

ule applies to all users if no greup(s) selected

o X5

Authenticate using.

Certificate (cloud deployment)

Password (cloud deployment)

Password (Local Directory)

12. In the Add Policy Rule page, add the following next to :

+ and user accessing content from : from the drop down select:- Windows 10
+ then the user may authenticate using: from the drop down select:- Certificate

(Cloud Deployment)

+ If the preceding method fails or is not applicable, then : from the drop down select:-
Password (cloud deployment)

+ Select +ADD FALLBACK METHOD

+ If the preceding method fails or is not applicable, then : from the drop down select:-
Password (Local Deployment)

+ Select SAVE

Certificate Based Authentication 2.0
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MNetwork Range Device Type Authentication Re-authenticate

ALL RANGES Web Browser Certificate (cloud depi.. 8 Hour(s)
ALL RANGES Workspace OME App .. Password (cloud deplo.. 2160 Hour(s)
ALL RANGES Windows 10 Certificate (cloud depl.. 8 Hour(s)

() ADD POLICY RULE

CANCEL

13. Select NEXT on the Edit Policy Page

1 Definition

2 Configuration

3 Summary

Definition

Mame

default_access_policy_set

Description

Default access policy set

Applications
O Application(s)

Configuration S

Policy Rule 1

f a user's netwerk range is ALL RANGES

and the user is accessing content from Windows 10
and the user belongs to the group(s) All Users

then the user may authenticate using Certificate (Cloud Deployment)

Fallback method 1: Password (cloud deployment)

Re-authenticate after 8 hour(s)

Advanced Properties A

BACK NEXT

CANCEL BACK SAVE

14. On the Edit Policy \ Summary page

+ Select SAVE..

* You have now enabled Certificate (Cloud Deployment) as an authentication method
on the default access policy.
+ Our next step is to ensure this implementation is working.

Certificate Based Authentication 2.0
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Part 3: Windows 10 Single Sign-On using Certificates

| 4 || = | Remote Desktops

« v 4 5> ThisPC > Desktop » Remote Desktops v & SearchF

Name Date modified
st Quick access
& AilWatch.RDP

[ Deskio
P % CaptureVM.RDP
¥ Downloads % C51-pell RDP
5] Documents % DEMProfiler.RDP
=] Pictures % IMP.RDP
DesktopInfo % PackagingVM.RDP
hol %, RDSHO1a.RDP
Rermote Desktops "5 saLroP
B TrueSSO.RDP
System32
Lo 3-01a RDP
I This PC 5 W1CClient01.RDP
[ Desktop. W10ClientD2.RDP
[ Documents % w10Parent02a.RDP
& Downloads % WorkspaceONE.RDP
B WS1-Connector.RDP
b Music
% WS2-Connector.RDP
=] Pictures
B videos
Windows Security x

Enter your credentials

These credentials will be used to connect to
W10Client01.euc-livefire.com.

e euc-livefire\administrator

sesesens e

[] Remember me
More choices

OK Cancel

1. On the Desktop of ControlCenter
* Open your Remote Desktops folder
* RDP to your Windows 10 Client (W10Client01.RDP)

+ Authenticated using :

+ Username euc-livefire\administrator
+ Password VMware1!

Certificate Based Authentication 2.0
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B W10Client01 - 172,16.30.106 - Remote Desktep Connection

New Tab x4

C 1| 2 aw-manfredvidmpreview.com

Google

Q, Search Google or type a URL b

2. Onyour W10Client01
« Open the Chrome Browser
* Navigate to Your unique Workspace ONE Access Tenant

@ hitps:/feasvidmpraview.com/ca: X | 4 B 2 =
“ ¢ @ cas.vidmpreview.com,/cas/t/ AW-MANFRED/API/1.0/REST/landing?EAB_CALLBACK_URL=%2Fauth%2Flogin%2Fembeddedaut.. ¥ e :
. x
Select a certificate
Select a certificate to authenticate yourself to casvidmpreview.com:443
Subject Isswer Senal
l Mark ManfredVogalgmailcom  0187FF
Certificate information oK Cancel

3. Onyour W10Client01
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* You will within a second get a prompt from Chrome to confirm the use of the installed
client certificate

Notice the URL has /cas which is the certificate authentication service that will validate
that certificate.

+ Select OK to confirm the use of the certificate.

NOTE: If you do not see the Certificate pop-up window, instead you are directed to the normal

Access authentication page. Go back to Part 1 in UEM and ensure the Certificate profile we have
published has been installed on the device.

Mware Inteligent Hub X 4

< C & aw-manfredvidmpreview.com/catalog-portal/uif/apps

@ Favorites Apps Far You Support

O; Search Apps
All Apps Categories v

All Apps

SAML TEST APP

~
(U0 I g

4. You should now be authenticated to the Intelligent Hub on the Chrome browser.

This concludes the Certificate-Based authentication lab, allowing users to authentication to
corporate resources securely from a managed Windows 10 device.
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Extra Material: Suppress Pop-up on Chrome Part 1

In the flow above the user's experience is not ideal requiring the user to manually select the
certificate from the prompt during authentication.

The various browsers handle the rules to auto-select certificates differently. In Chrome you
can do this either through registry files or Chrome ADMX policies as per this article.
https://www.chromium.org/administrators/policy-list-3#AutoSelectCertificateForUrls

In this lab we will show you both, first you will use the registry option and later we will use

the ADMP policy option using UEM.

Alternatively you can download the Chrome Policy templates here: http://dl.google.com/dl/
edgedl/chrome/policy/policy_templates.zip

7+ Quick access

I Desktop

& Downloads

=] Documents

=] Pictures
Carbon Black

i Local Disk (C)
Remote Desktops

System32

& ThisPC

Search Remote Desktops

-9 ADFS.RDP
b Citrix. RDP

& c0l enp
& W10Client01.RDP
X Ws1-Connector - Copy.RDP
& ws1-Connector.RDP
%} W10Client02.RDP

Disk O
Up Time
Lab Status

Type

Remete Desktop ...

p

E =
C:28GB/53GB (53% used
140 days - 23 hrs 17 min
Ready 04/02 08:16

1. On the Controlcenter base navigate to the

RDP to

Certificate Based Authentication 2.0

folder on the desktop and
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B3 W10Client01 - Simeon-lab.euc-livefire.com - Remote Desktop Connection

i Registry Edi!
= el registry Editor - See web results > App

£ registry editor free »
® ~ registry editor download free » = open
{ L registry editor command 5 55 Run as administrator
o Open file location
-3 Pin to Start
3 Pin to taskbar
5 registry Editor O G ] ﬂ

2. 0n the W10Client01 click Start and type registry editory and click on the Registry Editor

[ Registry Editor
File Edit View Favorites Help
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies

; ChDefense || Mame Type Data
> Ly Classes 2] (Defautt) REG_SZ fvalue not set)
> Clients

CVSM

DefaultUserEnvironn

» Google

> Intel

> Macromedia

> Microsoft

» ODBC

» OEM

> OpenssH

» Partner
- Prisis

Py Collapse

Re Mew

» T Find... ,

N T String Value

5 vl Delete Binary Value

> W Rename DWORD (32-bit) Value
» w b

i SvsT Export OWORD (64-bit) Value
. Multi-5tring Value
3 HKEY_U Permissions...

LIKEY Expandable String Value

< Copy Key Name
TR e tm LIVEV ~1IDDERIT 11EED _

3. Navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies

Right click Policies and click New > Key. Then Type Google.

Certificate Based Authentication 2.0 Export Date: 2024-01-09 04:26:44 -0500 Page 24



v Policies
) Microsoft
: Google
: Registers Expand
¥ Teradici Mew 5
) ThinPrini i
. Find... 5
» ViAware, String Value

4. Right Click on the Google and click New > Key. Then type Chrome.

» Partner
A Policies
Py Microsoft

W Google
' Chrome
: RegisteredAg Expand |
5 Teradici Mew 3 K
5 ThinPrint %

Find... e e

5. Right Click on Chrome and click New > Key. Then type AutoSelectCertificateForUrls

You should now have: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\
AutoSelectCertificateForUrls

B Registry Editor

File Edit View Favorites Help

Computer\HKEY_LOCAL_MACHIMNE\SOFTWARE\Policies\Googlel ChromelAutoSelectCertificatesForlrls

v | SOFTWARE ~ 1| Mame Type Data
> AIRWATCH

5 || AirWatchMDM
ChDefense

> Classes

REG_SZ (walue not set)

» Clients

CVSM
DefaultUserEnvironment
Google

Intel Mew 5 KEy
Macromedia

QDBC Binary value

OEM DWORD (32-bit) Value

OpenS5H )
OWORD (64-bit) Value

Partner
Policies Multi-String Value

B NV R R

> Microsoft Expandable String Value

.~ | Google
! v Chrome
AutoSelectCerti

Renicteredbnnlicratinne
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6. Right-Click in the white space inside the key AutoSelectCertificateForUrls and click New >
String Value

:p
JEVSOFTWARE \Policies\Googleh\Chromel AutoSelectCertificateForUrls
A 1| Mame Type Data
ab]| (Default) REG_SZ (value not set)
) 1 REG_SZ

7. Give the key the name 1

File Edit View Favorites Help
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\AutoSelect CertificateForlrls
TWARE || Name Type Data
!FfL""‘E"T':hr':'ﬂDM ab] (Default) REG_SZ (value not set)
iratc :

- REG 57
bDefense &
lasses
lients Modify Binary Data...
V3M Delete
efaultUserEnvircnment

Renamne

nnle

8. Right-click on the 1 and click Modify...
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File Edt View Fovorites Help
Compute\HKEY_LOCAL MACHINE\SOFTWAREPolicies\ Geogle) Chrome! AutoSelectCetificateForlils
SAM 1] Neme Tooe Dt
Edit String X (value not set)
K ["pattemn’:https://cas.vidmpreview.com”, filter"{...
Value name;
[1
Value data:
[ttem™tps /s vidmoeeview com” " Fhter” {ISSUER™{ CN'"emusk ]|
=
7T GaoglE T
Intel
Macromedia
Microsoft
oDBC
oM
a
@ File Aion View Favortes Window Help
e | anm 4L XEE Bm
| Local NonRemovable A | fosued To ) Issued By Expira
| Remote Desktop DTSRRI I S
Smart Card Trusted R | R CRISCR ermusk 23
| Trusted Packaged Ap
Trusted Devices
54 Certificate X
General  Detais  Ceriification Path
Show: [ <al> ~
Fieid Value ~
Centfi [ versan 3
d Ve ry User 1 Serial number 0135ab
| Truste | Signature gorithm shaS1RSA
| Thind-arty Root Cer M
Trusted People = 120 08:37:27
| Client Av " ;\'ﬂld:u 22 March 2030 08:37:27
ocal Nos Siiisrt 1ieer 3R <
v foN = emusk
Senart Card Tnicted R
< > <l
Personal store contains 2 certificates,

9. Fill in the Value data with the following replacing the highlighted text with the issuer value
from your certificate. This is the certificate issuer name. When using UEM certificates this is
the name of the Organization group from which the Certificate profile has been created.

{"pattern":"https://cas.vidmpreview.com","filter":{"ISSUER":{"CN":"emusk"}}}

Note: Some organizations may have multiple certificates issues by the same CA and will require
more detail in that scenario reference link at the top of the lab

EXAMPE:

Software\Policies\Google\Chrome\AutoSelectCertificateForUrls\1 =
"{"pattern":"https://www.example.com","filter":{"ISSUER":{"CN":"certificate issuer name", "L":
"certificate issuer location", "O": "certificate issuer org", "OU": "certificate issuer org unit"},
"SUBJECT":{"CN":"certificate subject name", "L": "certificate subject location", "O": "certificate
subject org", "OU": "certificate subject org unit"}}}"
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i Apps

Policies

Reload policies )| Export to JSON | Copy as JSON |

Status

Google update
Version: 1.3.36.72

Lagt fetched: 2 hours ago

Chrome Policies

Policy name Policy Value

AutoSelectCerti,, B4 {"pattern®:"https:/fcas. vidnorevien. con®, "filter":

Filter policies by name

_| Show policies with no value set

Status

ok Show more

Google Docs Offline

10. Open Chrome on W10Client01 and browse to chrome://policy

You should now notice that you have a Chrome Policy AutoSelectCertificateForUrls. This is a
sanity check to make sure that the Registry entry has been successfully created.

NOTE: if you do not see the policy. Click Reload policies in the top left at which point you
should see the policy appear.
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New Tab X 4+

C Y © aw-emuskvidmpreview.com
Apps o aw-emusk.vidmpreview.com
Q  aw-emuskvidmpreview.com - Google Search
L aw-emusk.vidmpreview.com/federation/auth/login
%) aw-emusk.vidmpreview.com/SAAS/auth/request
Q0  Intelligent Hub - aw.emusk.vidmpreview.com/federation/auth/response/interna
£} Favorites | Intelligent Hub x4 - B s
& C {t @ aw-emuskvidmpreview.com/catalog-portal/ui#/app-favorite r e H
Y Apps
0 Favorites Apps Peaple For You Support us

us User32 SCR

Favorites

Account

Sign out =
. service =
@ ﬁ" nuw

Microsoft Word Qutlook SernviceNow

Wabsite oD % Website © * Wabsite O %

11. In the navigation bar type the Workspace ONE Access URL and hit enter. You will be
authenticated and land on the Intelligent hub page.

You will notice a in the URL a redirect to cas.vidmpreview.com at which point the certificate gets
presented and validated, however the user is not prompted to select the certificate.

Extra Material: Suppress Pop-up on Chrome Part 2

In this part we will look at how we can automate the process so our entire fleet of Windows
10 managed devices will get the chrome policy to auto-select the appropriate certificate for
SSO in the Chrome browser.

We again have two options to realize this. One is to use the above registry option. Export
the registry, create a .bat file that installs the registry key and upload to UEM as Files/
Actions part of Product Provisioning.

The second option and the one we will use (just to change it up:) is to configure ADMX
template using CSP. We can do this using custom profiles as described here:

https://code.vmware.com/en/samples/3329/windows-10---chrome-admx#

First we will deploy the ADMX policy as part of a custom profile, then we will create a policy
that configures the "AutoSelectCertificateForURL"
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https://code.vmware.com/en/samples/3329/windows-10---chrome-admx

0
Qm.] Workspace ONE UEM Manfredvogal@gmail.com

_ _
CETTING Dashboard Devices » Profiles & Resources
STARTED
List View P
rofiles
Details View
MUHITOR Device Updates Filters » I
Lifecycle > Profile Details | Add profi nads
d Profiles & Resources v W10 - SCEP- 55C Upload Profile

DEWICES 'S

7 Windows Desktc
2 Baselines
AOTOUNTS
Resources
Batch Status
APPS & BOOKS Profiles Settings >

1. Open the Workspace ONE UEM admin console and navigate to Devices > Profiles &
Resources > Profiles > ADD click Add Profile

Windows

Select Device Type

(1 |
Ll |

Windows Desktop

W
VPN [s
D

Guard

Nata Bratection Winedews Hello

Select Context

a | L0

User Profile Device Profile

Settings will apply to the entire device, regardless
of user

Password

WiEl

VPN

Credentials

Restrictions

2. In the Add Profile window Select Windows > Windows Desktop and Device Profile
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3.

22 Add a New Windows Desktop Profile

| Find Payload |

I General

General

Password | Name * W10 - Chrome - ADMX |

Wi-Fi

Version 1
VPN
Credentials Description
Restrictions
Deployment Managed M
Defender Exploit
Guard
_ Assignment Type Auto hd
Data Protection
Windows Hello Allow Removal Always v

Firewall (Legacy)

ManfredVogal@gmail.com

i Managed By
Firewall
Anti-Virus
Smart Groups
Encryption

Windows Updates

Proxy

Exclusions
OEM Updates

@ Manfredvogal@gmail.com (Manfredvog
al@gmail.com)

Ftart typing to add a group Q

NO YES

In the General payload fill in the following:

Name ;: W10 - Chrome - ADMX

« Smart Groups - Select the World Icon for your Organization Group {should be you e-

mail address}

=8 Add a New Windows Desktop Profile

Find Payload

Defender Exploit
Guard

Data Protection
Windows Hello
Firewall (Legacy)
Firewall

Anti-Virus

Custom Settings

CONFIGURE

Encryption
Windows Updates
Proxy

OEM Updates
SCEP

Application Control
Windows Licensing
BIOS

Kiosk
Personalization

Peer Distribution

Custom Settings

SAVE AND PUBLISH CANCEL

4. On the left find Custom Settings payload and click CONFIGURE

Certificate Based Authentication 2.0

Export Date: 2024-01-09 04:26:44 -0500

Page 31



vmware {code}™ Q @ English | DCPartner Network | Training | Community | Flings | Store | Login :

Home Dev Centers APIs Samples SDKs Resources Join {CODE}

VMware {code} / Resources / Samples / Windows 10

Description
Windows 10 - Chrome ADMX

View on GitHub.com

- <Add><CmdID>1</CmdID><Item=<Meta><Format>chr</Format><Type>text/plain</Type></Meta><Target><LocURI>. Vendor/MSFT/Pol
<policyDefinitions revision="1.8" schemaVersion="1.8">
<policyNamespaces>
<target namespace="Google.Policies.Chrome” prefix="chrome"/>
<using namespace="Google.Policies" prefix="Google"/>
<using namespace="Microsoft.Policies.Windows" prefix="windows"/>

&= root
& Windows-Samples
& Custom Settings
B Chrome ADMX

Woo oL B W

</policyNamespaces>
X . Ceior M om
||3 ChromeADMXInstall.xmi <resources minRequiredRevision="1.8"/>
z <supportedOn>

[ sampleChromeSettings.xn 10 <definitions>

11 <definition displayName="3(string.SUPPORTED_WIN7)" name="SUPPORTED_WIN7"/>
B README.md 12 </definitions>

13 </supportedOn>
[4 chromehomepage 0 <categories>

15 <category displayName="$(string.googlechrome)" name="googlechrome">

16 <parentCategory ref="Google:Cat_Google"/>

17 </category>

10 cmmbmmnins df ew) o Mama PE P bt ma ananl ankmama wncsmmandadil mams W anaal acloass e sasms e d s

5. Open a new tab and navigate to https://code.vmware.com/en/samples/3329/windows-10---
chrome-admx#code
+ Click on Browse Code and Drill down to the ChromADMXinstall.xml
« Copy the entirety of the XML

22 Add a New Windows Desktop Profile X

Find Payload

Defender Exploit
Guard

Custom Settings

Target OMA DM Client v
Data Protection
TS M Make Commands
Atomic
Firewall (Legacy) B
Install Settings * valueName="SuppressUnsupportedOSWarning">
Firewall <parentCategory ref="googlechrome'/>
Antivirus <supportedOn ref="SUPPORTED_WIN7"/>
<enabledvalue=
Encryption <decimal value="1"/>
</enabledvalue>
Windows Updates <disabledValue>
<decimal value="0"/>
Proxy </disabledValue>
</policy>
OEM Updates <policy class="Both" displayName="$(string.SyncDisabled)"
explainText="$(string SyncDisabled_Explain)"
SCEP key="Software\Policies\Google\Chrome" name="SyncDisabled"

presentation="4(presentation.SyncDisabled)"
valueName="SyncDisabled">
<parentCategory ref="googlechrome"/>

Application Control
Windows Licensing
BIOS

Remove Settings *
Kiosk

Personalization

Peer Distribution

Custom Settings ©

SAVE AND PUBLISH CANCEL

6. Navigate back to the Workspace ONE UEM Console and paste the XML into the Install
Settings box of Custom Settings.
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Windows Hello
Firewall (Legacy)
Firewall

Anti-Virus
Encryption
Windows Updates
Proxy

OEM Updates
SCEP

Application Control
Windows Licensing
BIOS

Kiosk
Personalization

Peer Distribution

Custom Settings

Make Commands
Atomic

Install Settings *

Remove Settings *

[ e e e e

valueName="SuppressUnsupportedOSWarning"=
<supportedOn ref="SUPPORTED_WIN7"/>
<enabledValue>
<decimal value="1"/>
</enabledValue>
<disabledValue>
<decimal value="0"/>
</disabledValue>
</policy>
<policy class="Both" displayName="$(string.5yncDisabled)"
explainText="$(string.SyncDisabled_Explain)"
key="Software\Policies\Google\Chrome" name="SyncDisabled"
presentation="$(presentation.SyncDisabled)"
valueName="SyncDisabled"=
<parentCategory ref="googlechrome"/>

<Delete><CmdID=>1</CmdID><ltem><Meta=<Format>chr</Format=
<Type>text/plain</Type></Meta><Target>
<LocURI>./Vendor/MSFT/Policy/ ConfigOperations/ADMXInstall/Chrome/P

SAVE AND PUBLISH

CANCI

7. Paste the below XML into the Remove Settings box of the Custom Settings payload.

<Delete><CmdID>1</CmdID><Item><Meta><Format>chr</Format><Type>text/
plain</Type></Meta><Target><LocURI>./Vendor/MSFT/Policy/ConfigOperations/
ADMXInstall/Chrome/Policy/
ChromeAdmx</LocURI></Target><Data></Date></Item></Delete>

Remove Settings * <Delete><CmdID>1</CmdlD=<ltem><Meta=<Format>chr</Format>
=Type>text/plain</Type></Meta><Target>
<LocURI=./Vendor/MSFT/Policy/ConfigOperations/ADMXInstall/Chrome/P

©

SAVE AND PUBLISH CANCEL
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View Device Assignment

Assignment Status Friendly Name
@ Added Mark VMware7,1 Window...

Items 1-1 of 1

User

Mark

Assignment Status | All v

Windows Desktop / Windows...

/05/Model Phone Number

X

Filter Grid ¢

Organization Group
ManfredVogal@gmail.com

Page Size: | 20 v

PUBLISH | CANCEL

8. Click SAVE AND PUBLISH and PUBLISH on the View Device Assignment window.

List View
Profiles
Details View
MONITOR Device Updates Filters »
Lifecycle > Profile Details |Badd Profile & bads  Man
E‘-E"QII'IF Profiles & Resources v W10 - Chrome -| Upload Profile
S 9 Windows Desktc Mani
) Baselines O W.'l 0 - SCEP- 550
ACCOUNTS 7 Windows Desktop - User 1 Mant
Resources SCEP
Batch Status
9. Click ADD and Add Profile in the Profiles page.
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Select a platform to start:

Android Applei0S

Windows Android (Legacy)

Select Device Type

Windows Desktop

Select Context

al LD

User Profile Device Profile

10. Select Windows > Windows Desktop > User Profile

2% Add a New Windows Desktop Profile

| Find Payload |

General
VPN MName * W10 - Chrome - AutoSelect
Credentials
Version 1
Windows Hello
Single App Mode Description
‘Web Clips
Deployment Managed h
Exchange ActiveSync
SCEP Assignment Type Auto hd
Exchange Web
Services Allow Removal Always v
User Data
i Managed By ManfredVogal@gmail.com
Custom Settings
Smart Groups @ Manfredvogal@gmail.com (Manfredvog ®
al@gmail.com)
Start typing to add a group Q
Exclusions NO YES

11. In the General payload set the following:
* Name: W10 - Chrome - AutoSelect
« Smart Groups: Select the World Icon for your Organization Group {should be you e-mail
address}
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== Add a New Windows Desktop Profile

‘ Find Payload ‘

General

VPN
Credentials
Windows Hello

Custom Setti
Single App Mode ustom nes

CONFIGURE
Exchange ActiveSync
SCEP

Exchange Web
Services

User Data

Custom Settings

12. Go to the Custom Settings payload and click CONFIGURE

k::Add a New Windows Desktop Profile X

Credentials

Windows Hello

single App Mode

Web Clips

Exchange ActiveSync

SCEP.

12. Paste the following XML into the Install Settings section of Custom Settings. Replacing the
CN value (Highlighted) with your OrganisationGroup name without punctuation. (Eg.
ManfredVogalgmailcom) This is the Issuer value if you would like to double check on you
W10Client01 certificate.
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<Replace><CmdID>5</CmdID><Item><Target><LocURI>./Device/Vendor/MSFT/
Policy/Config/Chrome~Policy~googlechrome~ContentSettings/
AutoSelectCertificateForUrls</LocURI></Target><Data><! [CDATA [<enabled/><data
id="AutoSelectCertificateForUrlsDesc'

value="1&#xf000; {"pattern":"https://cas.vidmpreview.com","filter": {"ISSUER" : {"(

aecr

Exchange Web
Services

User Data

Custom Settings

Remove Settings * <Delete><CmdID>5</CmdID><ltem><Target>

<Data=</Data></Item></Delete>

o

SAVE AND PUBLISH CANCEL

13. Paste the following XML into the Remove Settings section of the Custom Settings.

<Delete><CmdID>5</CmdID><Item><Target><LocURI>./Device/Vendor/MSFT/
Policy/Config/Chrome~Policy~googlechrome~ContentSettings/
AutoSelectCertificateForUrls</LocURI></Target><Data></Data></Item></Delete>

<Data></Data></ltem></Delete>

©

SAVE AND PUBLISH CANCEL
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View Device Assignment X

Assignment Status | All v <
Assignment Status Friendly Name User Platfor Madel Phone Number Organization Group
@ rdded Mark VMware7,1 Window... Mark Windows Desktop / Windows... ManfredVogal@gmail.com
Items 1-1 of 1 Page Size: | 20 v

PUBLISH | CANCEL

14. Click SAVE AND PUBLISH and PUBLISH on the View Device Assignment window.

T-‘ @ Policies x  + - = ¢

RegycleBin ~ @ @ Chrome | chromey//policy # e :
Policies [Filter policies by name

7]
| Reload policies l Export to JSON ] Copy as JSON [CJ Show policies with no value set

7
| . Status
I
Google Update
Version: 1.3.36.72
ﬂq Enroliment domain: eucivefire.com

; Last fetched: 1 hour ago

Chrome Policies

Policy name Policy value Source Applies to Level Status

Google Docs Offline
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15. On the W10Client01 VM close Chrome and Re-open it. Navigate to Chrome://policy you
should see the AutoSelectCertificate policy there. Navigate to your unique WorkspaceONE
Access URL you should not be prompted for a certificate but it should be a seemless single-
sign-on experience.

This concludes the Certificate-Based Authentication on Windows 10 and the configuration

of the end-points to auto-select the appropriate certificate for single-sign on.

Author: Simeon Frank
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